安装VMWare Server 1.0.2

1.安装依赖包
sudo apt-get install linux-headers-`uname -r` build-essential xinetd

2.执行安装脚本
sudo ./vmware-install.pl

3.不能编译vmmon模块的错误和解决方法 ,出错提示 Unable to build the vmmon module.
解决方法:
解包并编辑:
cd /usr/lib/vmware/modules/source
sudo tar xvf vmmon.tar
sudo gedit vmmon-only/include/compat_kernel.h
找到第 21 行
static inline _syscall1(int, compat_exit, int, exit_code);
替换为
#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,19)
static inline _syscall1(int, compat_exit, int, exit_code);
#endif
接着打包并删除
sudo tar cvf vmmon.tar vmmon-only
sudo rm -rf vmmon-only

4.时间截止问题和解决方法,出错提示 Unable to get the last modification timestamp of the destination file /etc/vmware/ssl/rui.key.
解决方法:
sudo apt-get install ia32-libs (32位的系统不用装这个)
sudo /usr/bin/vmware-config.pl

5.搞掂!本文完成时已经出了 v1.0.3  :p

6.本文参考自 《如何在Ubuntu 7.04 Feisty(64bit)上安装VMWare Server 1.0.2 》 ( http://forum.ubuntu.org.cn/viewtopic.php?t=47136 ),有增减。

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据